Universal Access To All Knowledge
Home Donate | Store | Blog | FAQ | Jobs | Volunteer Positions | Contact | Bios | Forums | Projects | Terms, Privacy, & Copyright
Search: Advanced Search
Anonymous User (login or join us)
Upload

Reply to this post | See parent post | Go Back
View Post [edit]

Poster: suner Date: Nov 1, 2004 4:58am
Forum: feature_films Subject: Re: mpeg1 problems

It appears that these items seem to cause our derivation process some grief. I've tried to derive "artic_giant" twice and we're getting lots of weird errors in reading the mpeg file.
I'm not sure if the mpeg files are strangely formatted for our tools or if we've somehow corrupted them. I can get more "agile" with testing if a small mpeg item that has a similar problem can be found (all the items mentioned were decently large, 200MB+)

Reply to this post
Reply [edit]

Poster: Skip Elsheimer Date: Nov 3, 2004 12:49am
Forum: feature_films Subject: Test Clip...

Here's a clip from one of the offending MPEGs:

http://www.archive.org/details-db.php?mediatype=movies&identifier=test_clip

Reply to this post
Reply [edit]

Poster: suner Date: Nov 5, 2004 8:21am
Forum: feature_films Subject: Re: Test Clip...

Excellent! Thanks for the test clip.
Sure enough, it poops out just like the other films. As a full run to derive (which fails on the mp4s) takes about a minute, I should be able to try to figure out why it go boom as I have the time...

Thanks!

Reply to this post
Reply [edit]

Poster: Skip Elsheimer Date: Nov 16, 2004 2:30am
Forum: feature_films Subject: Re: Test Clip...

Any ideas why these files are causing problems?

Skip

Reply to this post
Reply [edit]

Poster: suner Date: Nov 16, 2004 3:22am
Forum: feature_films Subject: Re: Test Clip...

hokay, so I haven't been able to implement a fix, but I've at least chased it down to the fact that our version of "ffmpeg" is not liking the video track. I have an alternate video encoder (MPlayer-1.0pre5) that seems to be able to convert the video to mp4 OK (likely using a newer version of "ffmpeg" lib under the hood).

(The failure is something about buffer size problems).

However, I still need to:
1) programmatically *detect* the fact that ffmpeg is not happy (and my theory is to then use MPlayer as an alternate encoding when ffmpeg fails).
2) get MPlayer (or newer ffmpeg) installed and in our standard tools arsenal here

For now, you can try to encode the mpg/mpeg files with different parameters (and I can try our existing dervier tools on it), or wait until the fix is in place. (We have a big deadline push right now for a new machine cluster).

Reply to this post
Reply [edit]

Poster: A/V Geek Skip Date: Nov 1, 2004 5:10am
Forum: feature_films Subject: Re: mpeg1 problems

I'll clip one of these down in size and let you play with it.

Skip

Terms of Use (10 Mar 2001)